とりあえず作ってみたブログ

<< August 2019 | 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 >>

1回目の入れ替え

SSLの証明書の期限がそろそろ来るので、再取得。
httpdのconfを一時的に変えたのはいいけど、戻さないでhttpsアクセスして動かず・・・少しはまってしまった(T_T)
comments (0) | trackbacks (0)

SSL対応完了!

昨日の続きです。

 BLOGのスタイルシート問題はファイルの一括変換で対応しました。ってことで、http接続してもhttpsへ引き渡す、リダイレクトも有効にしています。

 多分、これでSSL化は完了です。もしブックマークされている方は、httpsの新しい方へ書き換えていただけると幸いです。(書き換えなくても支障はありませんけど)

#google先生の検索結果への復帰がいつになるかですねぇ~。
comments (0) | trackbacks (0)

SSL対応、仕切りなおし

 自宅WEBサーバのSSL対応、こちらの続きです。

○port443が重複してapache起動しなかった問題

 自宅ネットワーク内へ入れるようにVPNの穴を開けていたことがあります。着信設定がport443をListenしていたのでダメでした。長らく使っていないし、ルーターの転送もかけていないから着信設定を消しました。これで、無事にApacheが起動するようになりました。

○自作自演のオレオレ証明書を辞める

 opensslのコマンドラインで自作自演の証明書を作った場合は、公的な証明が得られないのでブラウザからお叱りが出ます。ってことで、SSLなう!にて手動生成してみました。

#こういうサイトは非常に重宝します。ありがとうございます(^^)

 オレオレ証明書では.keyや.csrファイルでしたが、取得したファイルは.pem。試したオレオレ証明書でもpemエンコードだったので、sslのconfファイルをpemファイル指定に書き換えておきます。

 使う鍵ファイルは、「サーバで使用する SSL 秘密鍵」「サーバ証明書 + 中間証明書」の2つであっているはずです。

○ルーターの設定変更

 これも忘れてはいけません。SSL用に443のポート転送を追加します。

○http→https自動リダイレクト

 Apacheのmod_rewiteを利用してhttpアクセスをすべてhttpsへ投げなおすようにconfを書き換えてみました。(参照はこちら)
 リダイレクトしたまでは良かったが、BLOGのCSSで引っかかり画面が崩れてしまいます。CSSの件が片付くまでhttpsへ完全移行できそうもありません。ってことで、リダイレクトは自分でテストだけして、外してしまいました。

 httpsでもサーバー的には運用できる状態になりました。スタイルシートの問題を片付けないと、完全なSSL化はできませんねぇ。今日はこれぐらいにしといたろう(^^;;;

#表示が崩れてもよければ https://jo3jye.ddo.jp/blog でアクセス可能です。
(SSL化が完了したため、表示が崩れません!。 2019/3/5修正)
comments (0) | trackbacks (0)

遅ればせながら手を付け始めました

 遅ればせながら、自宅webサーバのSSL対応に手をつけました。こちらの方はとっくの昔に対応されているのに、ウチはほったらかし。SSL対応をしていないので、google先生からも完全に見放され検索しても当WEBがリンクされなくなりました。これでは寂しいので、やはり手をつけてみました。

 前置きはさておき、今のところ、うまく動いていませんのでやったことの備忘録を並べておきます。

・参考先は、この3箇所。
 これぐらいにしといたろ
 オレオレ証明書をopensslでつくる
 Windows+ApacheでSSLを有効にする方法
・とりあえず、オレオレ証明書までは出来た。
・opensslのcnfファイルのpathでちょっとはまった。
#pathを指定したのに読まない(T_T)。何でだ?
・httpd.confとhttpd-ssl.confを書き換える。
・ssl.conf側のログ設定をコメントアウトしないとログの2度書きで起動しない。
・ログの二度書きをなすとokと思いきや、OSがらみのエラーっぽい記録があり、httpdが落ちていた(T_T)

 一旦ここで立ち止まって頭を冷やして考えてみます。何だろうねぇ。2.4系とはいえ、apacheが古いので新しくすることも考えたほうがいいのかな?

[2019.3.2 16:55追記]
httpdのListenで引っかかるようです。
webの80とhttpsの443。2ポート開いても問題ないはず。念のため80を閉じて443のみとしても同じ。どうやら443でListenできないと言うのが動かない理由と見てよさそうです。
ファイアーウォールの設定抜けかと思い、チェック。念のために、443も別途穴をあけてみたが・・ダメでした。
comments (2) | trackbacks (0)
1/1